Das grosse Archiv mit 638
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Sonstiges (11) ->

Ganzzahlige Zufallszahlen ohne Wiederholung ziehen (152)
 
 
Aufgabe
Aus einer Gesamtmenge von 150 Zahlen sollen zufällig 10 Zahlen ausgewählt werden, ohne, daß sich einzelne Zahlen wiederholen.

       A               B               C               D       
1 44  13  0,169327  66  
2 95  17  0,168891  22  
3 20  19  0,886315  17  
4 19  20  0,706615  13  
5 17  21  0,881266  56  
6 20  22  0,124155  95  
7 56  44  0,534972  44  
8 66  56  0,1738  20  
9 20  66  0,102459  21  
10 13  95  0,462566  19  
11        
12   (sortiert)    (unsortiert) 

Lösung
Die 10 Zufallszahlen für 150 Lose stehen in A1 bis A10.
=GANZZAHL(ZUFALLSZAHL()*150)+1

In B1 schreibst Du:
=MIN(A1:A10)

In B2 schreibst Du:
=WENN(KKLEINSTE(A$1:A$10;ZEILE())<=B1;B1+1;KKLEINSTE(A$1:A$10;ZEILE()))
B2 bis B10 runterkopieren.

Und eine Warnmeldung in B11 (falls duch das Addieren von 1 mal 151 dabei ist):
=WENN(B10>150;"nochmal berechnen";"")

Die Zufallszahlen sind jetzt aufsteigend sortiert; - ist dies nicht gewünscht schreibst Du:
in C1 bis C10 =ZUFALLSZAHL()
in D1 =INDEX(B$1:B$10;VERGLEICH(KKLEINSTE(C$1:C$10;ZEILE());C$1:C$10;0))
D1 bis D10 runterkopieren.
 
    zurück


 
powered by telltarget