Das grosse Archiv mit 638
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Summenfunktionen (9) ->

Nach Suchkriterium suchen und mehrere Spalten summieren (193)
 
 
Aufgabe
Es soll nach einem bestimmten Kriterium summiert werden, aber nicht nur eine Ergebnisspalte sondern mehrere.

       A               B               C               D               E               F       
1 x  769  184  190  859  467  
2 348  915  952  828  777  
3 748  389  730  790  745  
4 505  105  739  282  211  
5 x  550  934  249  916  635  
6 922  124  293  676  159  
7 x  858  739  585  133  800  
8 122  840  442  500  756  
9 529  444  712  615  212  
10 x  483  179  385  571  916  
11            
12 Summe  11.402         


Lösung
Suchspalte: A
Kriterium:"x"
zu summierende Spalten: B bis F
{=SUMME((A1:A100="x")*B1:F100)}

falls im Bereich B1:F100 Textzellen vorkommen können:
{=SUMME(WENN((A1:A100="x");B1:F100))}

Ergänzung
Das funktioniert auch für nicht angrenzende Spalten (hier C und E)
{=SUMME((A1:A100="x")*(C1:C100+E1:E100))}
sowie
{=SUMME(WENN((A1:A100="x");C1:C100+E1:E100))}

Die Spalten müssen jetzt aber einzeln angesprochen werden:
{=SUMME((A1:A100="x")*(C1:C100+E1:E100+F1:F100))} funktioniert; -
bei {=SUMME((A1:A100="x")*(C1:C100+E1:F100))} kommt Unsinn heraus


 
    zurück


 
powered by telltarget