Das grosse Archiv mit 627
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Sonstiges (11) ->

Alternative zur Ermittlung von Zufallszahlen ohne Wiederholungen (223)
 
 
Aufgabe
Es soll eine Lottoziehung 6 aus 49 simuliert werden.

Lösung
In A1 steht
=ZUFALLSZAHL()
diese Formel bis A49 runterkopieren.

In B1 steht:
=VERGLEICH(KKLEINSTE(A$1:A$49;ZEILE());A$1:A$49;0)
diese Formel bis B6 runterkopieren

noch kürzer, in B1 steht
=RANG(A1;A$1:A$49)
diese Formel bis B6 runterkopieren

Erläuterung
Es besteht eine Wahrscheinlichkeit von eins zu einer Billiarde (das ist eine 1 mit 15 Nullen), dass eine Wiederholung vorkommt. Soll es absolut wasserdicht sein, schreibt man von B1 bis B49 die Zahlen 1 bis 49 und läßt nach Spalte A sortieren. Die Zahlen von B1 bis B6 sind dann die Lottozahlen.
 
    zurück


 
powered by telltarget