Das grosse Archiv mit 628
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Verweisfunktionen (3) ->

Sverweisfunktion nach links (24)
 
 
Aufgabe
SVERWEIS durchsucht die erste Spalte einer Matrix und durchläuft die Zeile nach rechts, um den Wert einer Zeile zurückzugeben.
Was ist, wenn eine Spalte ermittelt werden soll, die links von der zu durchsuchenden Spalte steht - der SVERWEIS hat das nicht drauf ?

       A               B       
1 Müller  
2 Maier  
3 3  Schulze  
4 Meyer 

Es soll die Nummer von Schulze ausgegeben werden (3).

Lösung
Suchspalte: B
Ergebnisspalte: A
Suchbegriff:"Schulze"

=INDEX(A:A;VERGLEICH("Schulze";B:B;0))

Natürlich kann statt "Schulze" auch ein Zellbezug angegeben werden, in dem der zu suchende Name steht.

Beachte die 0 am Ende (Vergleichstyp)
Ist der Vergleichstyp gleich 0, liefert VERGLEICH den ersten Wert, der gleich dem Suchbegriff ist. Die Elemente der Suchspalte dürfen dann (und nur dann!) in beliebiger Reihenfolge angeordnet sein.

Ergänzung von Klaus "Perry" Pago:
Für die absoluten SVERWEIS-Nostalgiker geht es auch mit SVERWEIS:
=SVERWEIS("Schulze";WAHL({2.1};A1:A10;B1:B10);2;0)

Dabei funktionieren aber keine ganzen Spaltenangaben (A:A).
Ist mehr ne Spielerei als eine ernst gemeinte Alternative - aber beachtlich, dass es doch mit dem SVERWEIS - durch die mittels WAHL gespiegelte Matrix - geht. Eine schöne Idee, wie wir finden :-)

Erläuterung
Ich (WF) bin's jetzt langsam leid.
Die andauernde Frage: wer ist als erster auf die Kombi INDEX/VERGLEICH gekommen ?
Ich also am 22.10.2000

DOWNLOAD

Wer kann was Früheres bieten?




 
    zurück


 
powered by telltarget