Das grosse Archiv mit 621
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Zählfunktionen (4) ->

ZÄHLENWENN mit mehreren Bedingungen (273)
 
 
Aufgabe
Die Funktion ZÄHLENWENN durchsucht nur eine Spalte nach einem Suchkriterium.
Wenn alle Zeilen gezählt werden sollen, bei denen in der 1. Spalte ein bestimmtes Suchkriterium steht UND in der 2. Spalte ein weiteres, versagt ZÄHLENWENN.

       A               B       
1 b  
2 d  
3 x  y  
4 z  
5 h  
6 x  y  
7 y  
8 x  y  
9    
10 Anzahl  3 

Lösung
Zu durchsuchende Spalten: A und B

{=SUMME(WENN((A1:A100="x")*(B1:B100="y");1))}

ohne WENN:
{=SUMME((A1:A100="x")*(B1:B100="y"))}
oder:
{=SUMME(N(A1:A100&B1:B100="x"&"y"))}

auch ohne Array möglich (ausgetüftelt von Jürgen Recker):
=SUMMENPRODUKT((A1:A100="x")*(B1:B100="y"))

Durch die Multiplikation(en) sind natürlich auch mehr als 2 Bedingungen kombinierbar.

Erläuterung
NEU in Excel 2007:

=ZÄHLENWENNS(A:A;"x";B:B;"y")

oder

{=SUMME((A:A="x")*(B:B="y"))}

da neuerdings in Matrixformeln ganze Spalten auswählbar sind
 
    zurück


 
powered by telltarget