Das grosse Archiv mit 619
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Datum/Zeit (1) ->

Jahreskalender ganz schnell erstellen (284)

Autor: Werner Koopmann
 
 
Aufgabe
Wie kann man am schnellsten einen Jahreskalender mit Excel erstellen ?
Lösung
Mit einer einzigen formel wird ein kompletter Jahreskalender erzeugt.
In A1 steht die Jahreszahl vierstellig. (Zellformat Standard)
Die Zellen A2 bis L32 werden wie folgt formatiert:
TTT * TT.MMM.JJ
Folgende Formel wird in jede Zelle von A2 bis L32 kopiert.

=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-1))=SPALTE();DATUM($A$1;SPALTE();ZEILE()-1);"")

Fertig ist der Kalender.
Die Jahreszahl kann auch über eine Laufleiste vorgegeben werden.
Per bedingter formatierung von A2 bis L32 (formel ist:=WOCHENTAG(A2;2)>5)können noch die Wochenenden hervorgehoben werden.
Unterhalb des Kalenders kann die Osterformel (Nr. 3)(plus der Feiertage)
für eine weitere bedingte Formatierung sinnvoll eingesetzt werden.


ACHTUNG: Bitte keine Spalte oder Zeile vor dem Kalenderbereich einfügen.

 
    zurück


 
powered by telltarget