Das grosse Archiv mit 634
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Zählfunktionen (4) ->

Einträge in gefilterter Liste ohne Duplikate zählen (339)
 
 
Aufgabe
Eine Liste ist nach irgendeiner Spalte gefiltert.
Nun sollen die sichtbaren Einträge einer Spalte ohne Duplikate gezählt werden




Lösung
Die Einträge, die gezählt werden sollen, stehen in Spalte B2:B??

{=SUMME((VERGLEICH(WENN(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:100)));B2:B100);WENN(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:100)));B2:B100);0)=ZEILE(1:99))*(WENN(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:100)));A2:A100)<>FALSCH))}

Handelt es sich in Spalte B nur um Zahlen, funktioniert's ohne Array mit:
=SUMME((HÄUFIGKEIT(TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:100)))*(B2:B100);TEILERGEBNIS(3;INDIREKT("A"&ZEILE(2:100)))*(B2:B100))>0)*1)-1
Akzeptiert auch mehrere Spalten (B2:E100)

Einfacher und unabhängig von Text/Zahl::
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("B"&ZEILE(2:99)))*(VERGLEICH(B2:B99&"";B2:B99&"";0) =ZEILE(1:98)))
Darauf achten, dass ZEILE (solo am Ende) ein Zähler ist - also mit 1 beginnt - bei gleicher Länge (hier also bis 98).

Ist das Filterkriterium bekannt, funktioniert's ohne Teilergebnis und ohne Indirekt als Teil der Formel - z.B. für das Filterkriterium "x":
=SUMMENPRODUKT((B2:B99<>"")*(A2:A99="x")*(VERGLEICH(B2:B99&"";B2:B99&"";0)=ZEILE(1:98)))

 
    zurück


 
powered by telltarget