Das grosse Archiv mit 627
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Verweisfunktionen (3) ->

Koordinaten aus Suchbegriff in Zeile und Spalte bestimmen (39)
 
 
Aufgabe
Von einer Matrix soll die erste Spalte nach einem Suchbegriff durchsucht werden und die erste Zeile. Die dadurch festgelegten Koordinaten sollen das Ergebnis liefern.

       A               B               C               D               E               F               G       
1 a   b   g   x   f   g   h  
2 u   328   422   303   283   199   428  
3 v   338   356   250   137   472   254  
4 n   208   338   4   283   388   445  
5 a   208   328   409   276   435   86  
6 a   78   128   418   191   365   268  
7 y   207   39   93   305   445   393  
8 h   497   136   329   436   263   254  
9 e   36   477   375   185   320   137  
10 w   68   180   46   280   494   63  
11 Ergebnis   93            




Lösung
Matrix: A1:J100
Suchbegriff Zeile: "x"
Suchbegriff Spalte: "y"

=INDEX(A1:J100;VERGLEICH("y";A1:A100;0);VERGLEICH("x";A1:J1;0))

Für Nostalgiker eine Lösung mit dem SVERWEIS:
=SVERWEIS("y";A1:J100;VERGLEICH("x";A1:J1;0);0)

und umgekehrt - der Suchbegriff steht in M1
Spaltenüberschrift:
=INDEX(A1:J1;SUMMENPRODUKT((A1:J100=M1)*(SPALTE(A:J))))
Zeilenüberschrift:
=INDEX(A1:A100;SUMMENPRODUKT((A1:J100=M1)*(ZEILE(1:100))))

Kommt der Suchbegriff mehrfach vor: siehe Formel Nr. 58 (Tabellennavigation)

Erläuterung
Statt "x" und "y" natürlich auch Zellbezüge.
 
    zurück


 
powered by telltarget