Das grosse Archiv mit 634
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Listen/Datensätze (10) ->

alle möglichen Kombinationen zwischen MIN und MAX auflisten (453)
 
 
Aufgabe
wie der Titel schon sagt.

       A               B               C       
1 14  17   
2      
3 14  14  3  
4 14  15  3  
5 14  16  3  
6 14  17  3  
7 15  15  2  
8 15  16  2  
9 15  17  2  
10 16  16  1  
11 16  17  1  
12 17  17  0  
13     -1  
14     -1  
15     -1  
16     -1 

Lösung
Minimum steht in A1 - Maximum in B1

in A3 steht =A1
in A4: =WENN(MAX(A$3:A3)=B$1;"";WENN(ZÄHLENWENN(A$3:A3;A3)>C3;A3+1;A3))
A4 runterkopieren

in B3: =WENN(A3="";"";A3+ZÄHLENWENN(C$2:C2;C3))
B3 runterkopieren

C2 (hilfsspalte) ist leer
in C3 steht: =B1-A1
in C4: =WENN(A4<>A3;C3-1;C3)
C4 runterkopieren

 
    zurück


 
powered by telltarget