Das grosse Archiv mit 620
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
 
Sonstige (7) ->

Aktualisierung einer Summenformel beim Zeilen einfügen
 
 
Aufgabe
Das Problem kennt wahrscheinlich jeder:

Du hast einen Zahlenberereich, z.B. A1:A10 und berechnest in A11 die Summe =SUMME(A1:A10).
Nun müssen in dem Bereich nachträglich Werte ergänzt werden.
Also fügst Du vor A11 eine Zeile ein und trägst dort den neuen Wert ein.

Dieser wird dummer Weise nicht addiert, da in der Formel weiterhin =SUMME(A1:A10) steht. Also packst Du die Formel manuell an und ersetzt die 10 durch eine 11.

:-((
Lösung
Schreibe in A11 die Formel:
=SUMME(BEREICH.VERSCHIEBEN(A1;;;ZEILE()-ZEILE(A1)))

Die Formel muß nicht mehr geändert werden und rechnet immer alle Zellen oberhalb der Zelle, in der die Formel steht.


Falls oberhalb des Bereiches Zeilen eingefügt und in die Berechnung einbezogen werden sollen, dann:
=SUMME(INDIREKT("A1:A"&ZEILE()-1))
Können auch Spalten gelöscht oder eingefügt werden, dann:
=SUMME(INDIREKT(ADRESSE(1;SPALTE())&":"&ADRESSE(ZEILE()-1;SPALTE())))
Erläuterung
Ergänzung 23.03.2007

Über Extras>Optionen...>Bearbeiten>Datenbereich und Formeln erweitern
kann in den neueren Excelversionen auch dafür gesorgt werden, dass sich z.B. eine Summenformel auf einen erweiterten Datenbereich anpasst.
Man kann sich aber nicht in allen Konstellationen darauf verlassen, dass diese Option greift.
Z.B. wenn man Werte in den erweiterten Bereich reinkopiert oder per Makro reinschreibt oder Leerzeilen läßt versagt diese Option.
Umd sie funktioniert nur bei der Standardformel
=SUMME(BEREICH)

Wenn man die Formel nur geringfügig anpasst, z.B.
=SUMME(Bereich)*2
versagt das Autoerweitern schon

 
    zurück


 
powered by telltarget